Ye Olde Rocket Forum

Go Back   Ye Olde Rocket Forum > The Golden Age of Model Rocketry > Model Rocket History
User Name
Password
Auctions Register FAQ Members List Calendar Today's Posts Search Mark Forums Read


Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 11-17-2016, 08:13 PM
dwmzmm's Avatar
dwmzmm dwmzmm is offline
Master Modeler
 
Join Date: Apr 2005
Location: Katy, TX
Posts: 2,288
Default

I used the D13's a lot back in the days. Never had any problems with it until I tried to launch my Estes 1/100 Saturn - V at a Regional Meet (in 1972, I think) when it catoed immediately after liftoff. Thanks to a nice patch of soft grass that happen to be right next to the launch pad, the model landed on its' side on that grass and sustained no damage. I still have my last D13-3 from that batch in my collection. Around that time, I flew my Cineroc/Omega two stager using the D13's a few times (no problems encountered).
__________________
Dave, NAR # 21853 SR.
Section Advisor
Old Rocketeers # 724
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -5. The time now is 07:11 AM.


Powered by: vBulletin Version 3.0.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Ye Olde Rocket Shoppe 1998-2018